PHPUnitを実行すると「This version of PHPUnit is supported on PHP 7.0 and PHP 7.1. You are using PHP 5」と表示されるときの対処法

PHPUnitを実行すると「This version of PHPUnit is supported on PHP 7.0 and PHP 7.1. You are using PHP 5」と表示されるときの対処法

CSS

 PHPUnitを実行すると「This version of PHPUnit is supported on PHP 7.0 and PHP 7.1. You are using PHP 5」というメッセージが表示されてしまうときの対処法です。ていうか原因はそのままシリーズですね。

スポンサーリンク
GoogleAdSence レクタングル(大)

PHPUnit 5.7を使用する

 まあメッセージに書いてあるとおり、PHP 5.6で実行していました。

 PHPUnit (6.0系)は、PHP7以降の対応ということになっています。

 ではどうするかというと、その隣にある「Old Stable Release」の5.7を使います。

 こちらは

PHPUnit 5.7 is supported on PHP 5.6, PHP 7.0, and PHP 7.1.

ということで、PHP 5.6でも使用可能。